Услуги Сертификаты Новости Статьи База знаний Алгоритмы Портфолио Скачать Ссылки Поиск
Услуги arrow Статьи arrow Visual Studio 2008 SP1 и Team Explorer: проблемы и решения
Visual Studio 2008 SP1 и Team Explorer: проблемы и решения Версия для печати Отправить на e-mail
19.11.2008

На днях столкнулся с проблемой: установил SP1 на Visual Studio 2008 Team System.

 

Всё бы хорошо, но выяснилось, что после того, как установился SP1, он установил Frame Work 3.5 SP1, а вместе с ним перестал работать Team Explorer.

 

Начал искать в internet решения. 

 

Предложили решение №1: переставить студию, поставить на нее SP1, далее, переставить Team Explorer, затем снова поставить SP1 студии, чтобы он пропатчил Team Explorer. Теоретически, у многих этот момент срабатывает. Но мне не повезло.

 

Студия после данных операций работала, но проекты с TFS никак не хотели открываться. Точнее, мне вообще студия не давала возможность открыть проект: вылетало исключение - доступ запрещен. И никак не реагировали элементы управления Team Explorer из панели управления студии.

 

Я потратил какое-то время и выяснил, что если зайти в систему под локальным администратором, то всё работает,

но если под пользователем AD, даже включенным в группу администраторов, то студия наотрез отказывалась работать

как нужно.

 

Выход оказался простым: я запускаю студию от лица локального администратора. Согласитесь, это проще, чем переставить систему.

 

Т.к. в ходе экспериментов я выяснил, что корректно деинсталлировать FW 3.5 SP1 из системы очень трудно с первого раза.

 

Вернее, мне это не удалось. 

Последнее обновление ( 19.11.2008 )
 
< Пред.   След. >